HomeLegal DisclosuresBrowser Requirements

Browser and Operating System Requirements

Impact Bank highly recommends the latest browsers and operating systems for use with your Consumer Internet Banking and Business Internet Banking accounts. These items below have been approved to meet security and application requirements.

The following browsers and operating systems are compatible with Impact Bank's Consumer and Business Internet Banking.

Consumer Internet Banking

Browsers

  • Internet Explorer 9.0 or higher
  • Firefox
  • Safari
  • Google Chrome

Operating Systems

  • Windows Vista, 7, 8 and 8.1
  • Mac OS X 10.8, 10.9
  • iPad, iPad mini

Business Internet Banking

Browsers

  • Internet Explorer 7.0 or higher
  • Firefox
  • Safari

Operating Systems

  • Windows XP, 7
  • Mac OS X

If you have any questions regarding the browser and operating system requirements, you should contact Impact Bank at customerservice@impact-bank.com or by phone at (620)326-3361.